summaryrefslogtreecommitdiffstats
path: root/src/modules/eventeditor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/eventeditor/Makefile.am')
-rw-r--r--src/modules/eventeditor/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/modules/eventeditor/Makefile.am b/src/modules/eventeditor/Makefile.am
new file mode 100644
index 00000000..ceb7541a
--- /dev/null
+++ b/src/modules/eventeditor/Makefile.am
@@ -0,0 +1,21 @@
+###############################################################################
+# KVirc IRC client Makeeventeditor - 10.03.2000 Szymon Stefanek <stefanek@tin.it>
+###############################################################################
+
+AM_CPPFLAGS = -I$(SS_TOPSRCDIR)/src/kvilib/include/ -I$(SS_TOPSRCDIR)/src/kvirc/include/ \
+$(SS_INCDIRS) $(SS_CPPFLAGS) -DGLOBAL_KVIRC_DIR=\"$(globalkvircdir)\"
+
+pluglib_LTLIBRARIES = libkvieventeditor.la
+
+libkvieventeditor_la_LDFLAGS = -module -avoid-version $(SS_LDFLAGS) $(SS_LIBDIRS)
+
+libkvieventeditor_la_SOURCES = libkvieventeditor.cpp eventeditor.cpp
+nodist_libkvieventeditor_la_SOURCES = moc_eventeditor.cpp
+
+noinst_HEADERS = eventeditor.h
+libkvieventeditor_la_LIBADD = $(SS_LIBLINK) ../../kvilib/build/libkvilib.la
+
+# noinst_HEADERS=
+
+moc_eventeditor.cpp: eventeditor.h
+ $(SS_QT_MOC) $< -o $@