summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBert van Hall <bert.vanhall@gmx.de>2017-02-08 17:53:58 +0100
committerBert van Hall <bert.vanhall@gmx.de>2017-02-13 12:18:07 +0100
commitfe943395873c6cbfdfa0eadb8a5d13f2c95e8614 (patch)
tree7a8620e805fe7c1c5ce289cb82d84a3f16459719 /Makefile.am
parent2041bfd5cd6c6a8bcec260a3fa86d340050892c8 (diff)
downloadlibtdevnc-fe943395873c6cbfdfa0eadb8a5d13f2c95e8614.tar.gz
libtdevnc-fe943395873c6cbfdfa0eadb8a5d13f2c95e8614.zip
drop autotools
Since autotools officially is no longer supported (see various github issues), drop the related infrastructure to stop tempting people to use it for building. Signed-off-by: Bert van Hall <bert.vanhall@gmx.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 0 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index a7bc64d..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,28 +0,0 @@
-ACLOCAL_AMFLAGS = -I m4
-
-SUBDIRS=libvncserver examples libvncclient webclients client_examples test
-DIST_SUBDIRS=libvncserver examples libvncclient webclients client_examples test
-EXTRA_DIST = CMakeLists.txt rfb/rfbconfig.h.cmake
-
-bin_SCRIPTS = libvncserver-config
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libvncserver.pc libvncclient.pc
-
-includedir=$(prefix)/include/rfb
-
-include_HEADERS=rfb/rfb.h rfb/rfbconfig.h rfb/rfbproto.h \
- rfb/keysym.h rfb/rfbregion.h rfb/rfbclient.h
-
-$(PACKAGE)-$(VERSION).tar.gz: dist
-
-if HAVE_RPM
-# Rule to build RPM distribution package
-rpm: $(PACKAGE)-$(VERSION).tar.gz $(PACKAGE).spec
- cp $(PACKAGE)-$(VERSION).tar.gz @RPMSOURCEDIR@
- rpmbuild -ba $(PACKAGE).spec
-endif
-
-t:
- $(MAKE) -C test test
-