summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrunge <runge>2007-02-12 23:44:39 +0000
committerrunge <runge>2007-02-12 23:44:39 +0000
commit241f3ed566d34bf5b6c67ebebcc00727134d93b2 (patch)
treee42ddc70dc6a50503a2e22aef238c7a1fde7fb43 /configure.ac
parent0016cd4280ee9a0d088454a508a9c7f6bde33f62 (diff)
downloadlibtdevnc-241f3ed566d34bf5b6c67ebebcc00727134d93b2.tar.gz
libtdevnc-241f3ed566d34bf5b6c67ebebcc00727134d93b2.zip
x11vnc: add avahi (aka mDNS/Zeroconf/Bonjour...) support thanks to Diego Petteno. add -find -create
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b54cafd..8d35af3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,6 +335,33 @@ elif test "x$uname_s" = "xDarwin"; then
ld_minus_R="no"
fi
+AH_TEMPLATE(HAVE_AVAHI, [Avahi/mDNS client build environment present])
+AC_ARG_WITH(avahi,
+[ --without-avahi disable support for Avahi/mDNS]
+[ --with-avahi=DIR use avahi include/library files in DIR],,)
+if test "x$with_avahi" != "xno"; then
+ printf "checking for avahi... "
+ if test ! -z "$with_avahi" -a "x$with_avahi" != "xyes"; then
+ AVAHI_CFLAGS="-I$with_avahi/include"
+ AVAHI_LIBS="-L$with_avahi/lib -lavahi-common -lavahi-client"
+ echo "using $with_avahi"
+ with_avahi=yes
+ elif pkg-config --atleast-version=0.6.4 avahi-client >/dev/null 2>&1; then
+ AVAHI_CFLAGS=`pkg-config --cflags avahi-client`
+ AVAHI_LIBS=`pkg-config --libs avahi-client`
+ with_avahi=yes
+ echo yes
+ else
+ with_avahi=no
+ echo no
+ fi
+fi
+if test "x$with_avahi" = "xyes"; then
+ AC_DEFINE(HAVE_AVAHI)
+ AC_SUBST(AVAHI_CFLAGS)
+ AC_SUBST(AVAHI_LIBS)
+fi
+
AC_ARG_WITH(jpeg,
[ --without-jpeg disable support for jpeg]
[ --with-jpeg=DIR use jpeg include/library files in DIR],,)