summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2011-09-11 21:02:55 +0200
committerChristian Beier <dontmind@freeshell.org>2011-09-11 21:02:55 +0200
commitfa458d48ec69321f9694a2cdcf147c46554bcf75 (patch)
tree9d839428ed49ffb0bc985ec57fb680fa76431149 /configure.ac
parent431518add49d3542c61a47f2b919acfac214753d (diff)
downloadlibtdevnc-fa458d48ec69321f9694a2cdcf147c46554bcf75.tar.gz
libtdevnc-fa458d48ec69321f9694a2cdcf147c46554bcf75.zip
Autotools: Fix OpenSSL and GnuTLS advertisement.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 79ce830..36406e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,7 +145,7 @@ something like libssl-dev) and run configure again.
[AC_DEFINE(HAVE_X509_PRINT_EX_FP) HAVE_X509_PRINT_EX_FP="true"], , $SSL_LIBS
)
fi
-AM_CONDITIONAL(HAVE_LIBSSL, test "x$with_crypto" != "xno" -a "x$with_ssl" != "xno")
+AM_CONDITIONAL(HAVE_LIBSSL, test ! -z "$SSL_LIBS")
# Checks for X libraries
HAVE_X11="false"
@@ -795,6 +795,7 @@ if test "x$with_gnutls" != "xno"; then
AC_DEFINE(WITH_CLIENT_TLS)
fi
fi
+AM_CONDITIONAL(HAVE_GNUTLS, test ! -z "$GNUTLS_LIBS")
# IPv6
AH_TEMPLATE(IPv6, [Enable IPv6 support])