summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authordscho <dscho>2004-06-07 08:31:57 +0000
committerdscho <dscho>2004-06-07 08:31:57 +0000
commit2b8c2a5c3a71364e402b4df334a6f5aff5ed77a9 (patch)
tree66e59b58f919f5848780d5c7d6c954160e289cff /examples/Makefile.am
parent98e4f89569587c143a56e4dcf8162a035efc361e (diff)
downloadlibtdevnc-2b8c2a5c3a71364e402b4df334a6f5aff5ed77a9.tar.gz
libtdevnc-2b8c2a5c3a71364e402b4df334a6f5aff5ed77a9.zip
add client_examples/, add SDLvncviewer, libvncclient API changes, suppress automake CFLAGS nagging
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 18f3726..ff816ac 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,21 +1,14 @@
-CFLAGS=-I.. -g -Wall
+DEFINES=-I.. -g -Wall
LDADD = ../libvncserver/libvncserver.a
-if HAVE_LIBPTHREAD
-BACKGROUND_TEST=blooptest
-endif
-
if OSX
MAC=mac
mac_LDFLAGS=-framework ApplicationServices -framework Carbon -framework IOKit
endif
-copyrecttest_LDADD=$(LDADD) -lm
-
noinst_HEADERS=radon.h
noinst_PROGRAMS=example pnmshow regiontest pnmshow24 fontsel \
- vncev storepasswd colourmaptest simple simple15 copyrecttest \
- $(BACKGROUND_TEST) $(MAC)
+ vncev storepasswd colourmaptest simple simple15 $(MAC)