summaryrefslogtreecommitdiffstats
path: root/libvncserver/Makefile.am
diff options
context:
space:
mode:
authorJoel Martin <github@martintribe.org>2011-08-16 14:02:31 +0200
committerJohannes Schindelin <johannes.schindelin@gmx.de>2011-08-17 12:41:23 +0200
commit6fac22a74b5020387a6961e4cc197b5fa4743f96 (patch)
tree9eb15702fbeed2f15fe2de17b54ac92544582509 /libvncserver/Makefile.am
parent353b35e86aa7d51d767f4ff66e1179105bbee205 (diff)
downloadlibtdevnc-6fac22a74b5020387a6961e4cc197b5fa4743f96.tar.gz
libtdevnc-6fac22a74b5020387a6961e4cc197b5fa4743f96.zip
websockets: Initial WebSockets support.
Has a bug: WebSocket client disconnects are not detected. rfbSendFramebufferUpdate is doing a MSG_PEEK recv to determine if enough data is available which prevents a disconnect from being detected. Otherwise it's working pretty well. [jes: moved added struct members to the end for binary compatibility with previous LibVNCServer versions, removed an unused variable] Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
Diffstat (limited to 'libvncserver/Makefile.am')
-rw-r--r--libvncserver/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libvncserver/Makefile.am b/libvncserver/Makefile.am
index a685ed1..0d64363 100644
--- a/libvncserver/Makefile.am
+++ b/libvncserver/Makefile.am
@@ -12,6 +12,10 @@ TIGHTVNCFILETRANSFERSRCS = tightvnc-filetransfer/rfbtightserver.c \
tightvnc-filetransfer/filelistinfo.c
endif
+if WITH_WEBSOCKETS
+WEBSOCKETSSRCS = websockets.c md5.c
+endif
+
includedir=$(prefix)/include/rfb
#include_HEADERS=rfb.h rfbconfig.h rfbint.h rfbproto.h keysym.h rfbregion.h
@@ -37,7 +41,7 @@ endif
endif
endif
-LIB_SRCS = main.c rfbserver.c rfbregion.c auth.c sockets.c \
+LIB_SRCS = main.c rfbserver.c rfbregion.c auth.c sockets.c $(WEBSOCKETSSRCS) \
stats.c corre.c hextile.c rre.c translate.c cutpaste.c \
httpd.c cursor.c font.c \
draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ../common/minilzo.c ultra.c scale.c \