summaryrefslogtreecommitdiffstats
path: root/libvncserver/Makefile.am
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2011-01-25 17:32:24 +0100
committerChristian Beier <dontmind@freeshell.org>2011-01-25 17:36:00 +0100
commitffe30366d63fd318f0ee3b55dd9a60642bfb5d88 (patch)
tree62a6b6b3c6157794619b63a81d4f8fcc7c45e6b0 /libvncserver/Makefile.am
parent5e1488beb3903b2d3fa2fd2457f8bff781033d9a (diff)
downloadlibtdevnc-ffe30366d63fd318f0ee3b55dd9a60642bfb5d88.tar.gz
libtdevnc-ffe30366d63fd318f0ee3b55dd9a60642bfb5d88.zip
Put files used by both libs into a 'common' dir.
No functional changes. All files used by _both_ libvncserver and libvncclient are put into a 'common' directory and references from other files as well as Autotools and CMake build systems are updated. Signed-off-by: Christian Beier <dontmind@freeshell.org>
Diffstat (limited to 'libvncserver/Makefile.am')
-rw-r--r--libvncserver/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/libvncserver/Makefile.am b/libvncserver/Makefile.am
index 0ad7a05..d85bf81 100644
--- a/libvncserver/Makefile.am
+++ b/libvncserver/Makefile.am
@@ -1,4 +1,4 @@
-INCLUDES = -I$(top_srcdir)
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/common
if WITH_TIGHTVNC_FILETRANSFER
TIGHTVNCFILETRANSFERHDRS=tightvnc-filetransfer/filelistinfo.h \
@@ -18,8 +18,8 @@ includedir=$(prefix)/include/rfb
include_HEADERS=../rfb/rfb.h ../rfb/rfbconfig.h ../rfb/rfbint.h \
../rfb/rfbproto.h ../rfb/keysym.h ../rfb/rfbregion.h ../rfb/rfbclient.h
-noinst_HEADERS=d3des.h ../rfb/default8x16.h zrleoutstream.h \
- zrlepalettehelper.h zrletypes.h private.h minilzo.h lzoconf.h scale.h \
+noinst_HEADERS=../common/d3des.h ../rfb/default8x16.h zrleoutstream.h \
+ zrlepalettehelper.h zrletypes.h private.h ../common/minilzo.h ../common/lzoconf.h scale.h \
$(TIGHTVNCFILETRANSFERHDRS)
EXTRA_DIST=tableinit24.c tableinittctemplate.c tabletranstemplate.c \
@@ -27,7 +27,7 @@ EXTRA_DIST=tableinit24.c tableinittctemplate.c tabletranstemplate.c \
zrleencodetemplate.c
if HAVE_LIBZ
-ZLIBSRCS = zlib.c zrle.c zrleoutstream.c zrlepalettehelper.c zywrletemplate.c
+ZLIBSRCS = zlib.c zrle.c zrleoutstream.c zrlepalettehelper.c ../common/zywrletemplate.c
if HAVE_LIBJPEG
JPEGSRCS = tight.c
endif
@@ -36,7 +36,7 @@ endif
LIB_SRCS = main.c rfbserver.c rfbregion.c auth.c sockets.c \
stats.c corre.c hextile.c rre.c translate.c cutpaste.c \
httpd.c cursor.c font.c \
- draw.c selbox.c d3des.c vncauth.c cargs.c minilzo.c ultra.c scale.c \
+ draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ../common/minilzo.c ultra.c scale.c \
$(ZLIBSRCS) $(JPEGSRCS) $(TIGHTVNCFILETRANSFERSRCS)
libvncserver_la_SOURCES=$(LIB_SRCS)