summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt77
1 files changed, 55 insertions, 22 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index feca7c96d..ed7519be0 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -1,31 +1,64 @@
+#################################################
+#
+# (C) 2021 Michele Calgaro
+# Michele (DOT) Calgaro (AT) yahoo.it
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TQT_INCLUDE_DIRS}
)
-set(polkit_tqt_core_SRCS
- polkittqt1-authority.cpp
- polkittqt1-identity.cpp
- polkittqt1-subject.cpp
- polkittqt1-temporaryauthorization.cpp
- polkittqt1-details.cpp
- polkittqt1-actiondescription.cpp
+link_directories(
+ ${TQT_LIBRARY_DIRS}
)
-automoc4_add_library(polkit-tqt-core-1 SHARED ${polkit_tqt_core_SRCS})
-target_link_libraries(polkit-tqt-core-1
- ${TQT_TQTCORE_LIBRARY}
- ${TQT_TQTDBUS_LIBRARY}
- ${TQT_TQTXML_LIBRARY}
- ${POLKIT_LIBRARIES}
- ${GLIB2_LIBRARIES}
- ${GOBJECT_LIBRARIES}
- ${GIO_LIBRARIES}
+##### install headers ###########################
+
+install( FILES
+ dummy-core.h
+ DESTINATION ${INCLUDE_INSTALL_DIR} )
+
+
+##### polkit-tqt-core (shared) #########################
+
+tde_add_library( polkit-tqt-core SHARED AUTOMOC
+ SOURCES ${polkit_tqt_MOCS}
+ dummy-core.cpp
+ VERSION 0.0.0
+ LINK ${TQT_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
)
-set_target_properties(polkit-tqt-core-1 PROPERTIES VERSION ${POLKITTQT-1_LIBRARY_VERSION}
- SOVERSION ${POLKITTQT-1_ABI_VERSION}
- DEFINE_SYMBOL MAKE_POLKITTQT1_LIB)
-install(TARGETS polkit-tqt-core-1 ${INSTALL_TARGETS_DEFAULT_ARGS})
+## set(polkit_tqt_core_SRCS
+## polkittqt1-authority.cpp
+## polkittqt1-identity.cpp
+## polkittqt1-subject.cpp
+## polkittqt1-temporaryauthorization.cpp
+## polkittqt1-details.cpp
+## polkittqt1-actiondescription.cpp
+## )
+##
+## target_link_libraries(polkit-tqt-core-1
+## ${TQT_TQTCORE_LIBRARY}
+## ${TQT_TQTDBUS_LIBRARY}
+## ${TQT_TQTXML_LIBRARY}
+## ${POLKIT_LIBRARIES}
+## ${GLIB2_LIBRARIES}
+## ${GOBJECT_LIBRARIES}
+## ${GIO_LIBRARIES}
+## )
+##
+## set_target_properties(polkit-tqt-core-1 PROPERTIES VERSION ${POLKITTQT-1_LIBRARY_VERSION}
+## SOVERSION ${POLKITTQT-1_ABI_VERSION}
+## DEFINE_SYMBOL MAKE_POLKITTQT1_LIB)
+##
+## install(TARGETS polkit-tqt-core-1 ${INSTALL_TARGETS_DEFAULT_ARGS})