summaryrefslogtreecommitdiffstats
path: root/examples/agent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/agent/CMakeLists.txt')
-rw-r--r--examples/agent/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/examples/agent/CMakeLists.txt b/examples/agent/CMakeLists.txt
new file mode 100644
index 000000000..ba708cb46
--- /dev/null
+++ b/examples/agent/CMakeLists.txt
@@ -0,0 +1,24 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/agent
+)
+
+set(polkit_agent_example_SRCS
+ main.cpp
+ pkagentexample.cpp
+ klistener.cpp
+)
+
+automoc4(polkit-agent-example polkit_agent_example_SRCS)
+
+add_executable(polkit-agent-example
+ ${polkit_agent_example_SRCS}
+)
+
+target_link_libraries(polkit-agent-example
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ polkit-qt-agent-1
+ polkit-qt-core-1
+)