summaryrefslogtreecommitdiffstats
path: root/app_templates/kdeapp/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'app_templates/kdeapp/setup.py')
-rwxr-xr-xapp_templates/kdeapp/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/app_templates/kdeapp/setup.py b/app_templates/kdeapp/setup.py
new file mode 100755
index 0000000..8cf6964
--- /dev/null
+++ b/app_templates/kdeapp/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/python
+###########################################################################
+# setup - description #
+# ------------------------------ #
+# begin : Fri Jun 27 2003 #
+# copyright : (C) 2003-2004 by AUTHOR #
+# email : YOUR@EMAIL.com #
+# #
+###########################################################################
+# #
+# This program is free software; you can redistribute it and/or modify #
+# it under the terms of the GNU General Public License as published by #
+# the Free Software Foundation; either version 2 of the License, or #
+# (at your option) any later version. #
+# #
+###########################################################################
+
+import kdedistutils
+
+kdedistutils.setup(name="kdeapp",
+ version="0.1.0",
+ author="AUTHOR",
+ author_email="YOUR@EMAIL.com",
+ url="http://www.KDEAPP.com/",
+ min_kde_version = "3.0.0",
+ min_qt_version = "3.0.0",
+ license = "GPL",
+ application_data = ['src/kdeapp.py','src/prefdialog.py','src/kdeappview.py'],
+ executable_links = [('kdeapp','kdeapp.py')],
+ docbooks = [ ('doc/en','en') ] )