summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt38
1 files changed, 15 insertions, 23 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index a653d59..c752e63 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,25 +1,17 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
-# Automatic discovery of sources
-FILE(GLOB PO_FILES *.po)
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} rosegarden.po )
-# DISABLED: explicit set of source files
-# SET(PO_FILES
-# ca.po
-# cs.po
-# cy.po
-# de.po
-# en_GB.po
-# en.po
-# es.po
-# et.po
-# fi.po
-# fr.po
-# it.po
-# ja.po
-# nl.po
-# ru.po
-# sv.po
-# zh_CN.po
-# )
-
-ADD_TRANSLATIONS(rosegarden ${PO_FILES})
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} PATH )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )