summaryrefslogtreecommitdiffstats
path: root/trinity-base/kicker/files
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
committerChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
commit55d2aaa4eb5201ac97e269fc141e4ee1778379b8 (patch)
tree810ece5e004aa9e97e26a1ad988ed52552175fb6 /trinity-base/kicker/files
parent644110a847c5911c2eb04eb53c93031740561efc (diff)
downloadtde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.tar.gz
tde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.zip
Clean up and fix TDE Gentoo overlay.
- Remove old v3.5.13 ebuilds and eclasses - Change repo URL to official TGW - Remove old HAL and traces (TDEHW is used now) - Make split between TDE applications and tdebase consistent - Move TQt into own category (for users filtering dev-qt/ out) - Change to new TQTDIR var - Move away from virtual/pam dependency - Change to use new xorg-proto dependency - Some cosmetic fixes and removal of unneeded files - Remove some now obsolete patches - Change to clean 9999 naming scheme for anything - Add some potential workaround for newer portage versions - Add own README ... thanks to Aggi from IRC for some fixes too. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/kicker/files')
-rw-r--r--trinity-base/kicker/files/kicker-3.5.13.2-include-dbus.patch51
1 files changed, 0 insertions, 51 deletions
diff --git a/trinity-base/kicker/files/kicker-3.5.13.2-include-dbus.patch b/trinity-base/kicker/files/kicker-3.5.13.2-include-dbus.patch
deleted file mode 100644
index ddfbd9e4..00000000
--- a/trinity-base/kicker/files/kicker-3.5.13.2-include-dbus.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/ConfigureChecks.cmake b/ConfigureChecks.cmake
-index 8dc8a3f..24c47df 100644
---- a/ConfigureChecks.cmake
-+++ b/ConfigureChecks.cmake
-@@ -233,8 +233,8 @@ find_package( TQt )
- find_package( TDE )
-
-
--# dbus (kdm, ksmserver)
--if( BUILD_KDM OR BUILD_KSMSERVER )
-+# dbus (kdm, ksmserver, kicker)
-+if( BUILD_KDM OR BUILD_KSMSERVER OR BUILD_KICKER )
-
- pkg_search_module( DBUS dbus-1 )
- if( NOT DBUS_FOUND )
-diff --git a/kicker/kicker/buttons/CMakeLists.txt b/kicker/kicker/buttons/CMakeLists.txt
-index 1e7ede5..18e8601 100644
---- a/kicker/kicker/buttons/CMakeLists.txt
-+++ b/kicker/kicker/buttons/CMakeLists.txt
-@@ -18,6 +18,7 @@ include_directories(
- ${CMAKE_SOURCE_DIR}/kicker/kicker/ui
- ${CMAKE_SOURCE_DIR}/libkonq
- ${DBUS_TQT_INCLUDE_DIRS}
-+ ${DBUS_INCLUDE_DIRS}
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
- )
-diff --git a/kicker/kicker/core/CMakeLists.txt b/kicker/kicker/core/CMakeLists.txt
-index f2eb010..c850ff5 100644
---- a/kicker/kicker/core/CMakeLists.txt
-+++ b/kicker/kicker/core/CMakeLists.txt
-@@ -18,6 +18,7 @@ include_directories(
- ${CMAKE_SOURCE_DIR}/kicker/kicker/ui
- ${CMAKE_SOURCE_DIR}/kicker/kicker/buttons
- ${DBUS_TQT_INCLUDE_DIRS}
-+ ${DBUS_INCLUDE_DIRS}
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
- )
-diff --git a/kicker/kicker/ui/CMakeLists.txt b/kicker/kicker/ui/CMakeLists.txt
-index a6e9510..8929962 100644
---- a/kicker/kicker/ui/CMakeLists.txt
-+++ b/kicker/kicker/ui/CMakeLists.txt
-@@ -21,6 +21,7 @@ include_directories(
- ${CMAKE_SOURCE_DIR}/kdmlib
- ${CMAKE_SOURCE_DIR}/libkonq
- ${DBUS_TQT_INCLUDE_DIRS}
-+ ${DBUS_INCLUDE_DIRS}
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
- )