summaryrefslogtreecommitdiffstats
path: root/trinity-base/noatun-plugins/noatun-plugins-14.0.8.ebuild
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-07-18 16:35:05 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-27 23:53:26 +0100
commitfa1bdbfe2bea483448a8becc21c438afca3e43a4 (patch)
tree6e23d13fbbc3fcc91d4441ca459d1c7b1994f651 /trinity-base/noatun-plugins/noatun-plugins-14.0.8.ebuild
parentcfcb6c94f410685c528f63141ba4497e454bf8b3 (diff)
downloadtde-packaging-gentoo-fa1bdbfe2bea483448a8becc21c438afca3e43a4.tar.gz
tde-packaging-gentoo-fa1bdbfe2bea483448a8becc21c438afca3e43a4.zip
Unmasked noatun-plugins and added an ebuild, since noatun is now available. Note blacklist of berkdb support--the build system couldn't find the lib.
Diffstat (limited to 'trinity-base/noatun-plugins/noatun-plugins-14.0.8.ebuild')
-rw-r--r--trinity-base/noatun-plugins/noatun-plugins-14.0.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/trinity-base/noatun-plugins/noatun-plugins-14.0.8.ebuild b/trinity-base/noatun-plugins/noatun-plugins-14.0.8.ebuild
new file mode 100644
index 00000000..ae423287
--- /dev/null
+++ b/trinity-base/noatun-plugins/noatun-plugins-14.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdeaddons"
+
+inherit trinity-meta-2 db-use
+
+need-arts optional
+
+DESCRIPTION="Various plugins for Noatun."
+KEYWORDS="~amd64 ~x86"
+
+IUSE+=" sdl berkdb"
+
+COMMON_DEPEND="
+ ~trinity-base/noatun-${PV}
+"
+# berkdb? ( =sys-libs/db-4*:= )
+#"
+DEPEND+=" ${COMMON_DEPEND}
+ sdl? ( media-libs/libsdl )
+"
+
+RDEPEND+=" ${COMMON_DEPEND}
+ sdl? ( media-libs/libsdl[X] )
+"
+
+src_compile() {
+ mycmakeargs=(
+ -DWITH_SDL="$(usex sdl)"
+ )
+
+# if use berkdb; then
+# mycmakeargs=( "${mycmakeargs[@]}"
+# -DWITH_BERKELEY_DB=ON
+# -DBERKELEY_DB_LIBS="$(db_libname)"
+# -DBERKELEY_DB_INCLUDE_DIRS="${ROOT}$(db_includedir)"
+# )
+# else
+ mycmakeargs=( "${mycmakeargs[@]}"
+ -DWITH_BERKELEY_DB=OFF
+ )
+# fi
+
+ trinity-meta-2_src_configure
+}