summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdebase-doc/tdebase-doc-9999.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-28 10:56:09 +0300
committerormorph <roma251078@mail.ru>2023-04-28 10:58:56 +0300
commit781ddbe5e80e784826dd3819cbacb04f6ac7a3ac (patch)
treecdc508ddde6dd89157084185ea002f1edb18a5f2 /trinity-base/tdebase-doc/tdebase-doc-9999.ebuild
parent48e81b686bc71329df6a9e9dcd001badd6e8c4e2 (diff)
downloadtde-packaging-gentoo-781ddbe5e80e784826dd3819cbacb04f6ac7a3ac.tar.gz
tde-packaging-gentoo-781ddbe5e80e784826dd3819cbacb04f6ac7a3ac.zip
Adding the tdebase-doc ebuild
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tdebase-doc/tdebase-doc-9999.ebuild')
-rw-r--r--trinity-base/tdebase-doc/tdebase-doc-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/trinity-base/tdebase-doc/tdebase-doc-9999.ebuild b/trinity-base/tdebase-doc/tdebase-doc-9999.ebuild
new file mode 100644
index 00000000..bf8554f6
--- /dev/null
+++ b/trinity-base/tdebase-doc/tdebase-doc-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2
+
+DESCRIPTION="Documentation for tdebase-derived packages"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ ~trinity-base/khelpcenter-${PV}
+"
+
+src_prepare() {
+ sed 's/tde_conditional_add_project_docs( BUILD_DOC )/tde_conditional_add_subdirectory( BUILD_DOC doc )/' -i "${S}/CMakeLists.txt" || die
+ trinity-meta-2_src_prepare
+}
+
+src_install() {
+ trinity-meta-2_src_install
+ rm -rf "${D}/usr/trinity/14/bin"
+ rm -rf "${D}//usr/trinity/14/share/autostart"
+}