summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbibtex
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kbibtex')
-rw-r--r--trinity-apps/kbibtex/Manifest1
-rw-r--r--trinity-apps/kbibtex/kbibtex-14.1.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/kbibtex/Manifest b/trinity-apps/kbibtex/Manifest
index eaee9f9e..65bea122 100644
--- a/trinity-apps/kbibtex/Manifest
+++ b/trinity-apps/kbibtex/Manifest
@@ -1 +1,2 @@
DIST kbibtex-trinity-14.1.1.tar.xz 285640 BLAKE2B 8db0a0b674bd0b91b867680939acaddb1399b965ddf1f4fb0159bac60e79d3bf72e04eea9b5f4680b45936268c4cd3ddfa599b8db6a2bc522f0a98a1d836d910 SHA512 af644c7f0b0624d7c1ddd3665007e82d2f402f2231d19dfa9c0c412b05a7b467509f8155b6610718f750d22fa28429f358a12e834c99b461a38168bba6c6dbee
+DIST kbibtex-trinity-14.1.2.tar.xz 281428 BLAKE2B fe12be20c2206176ae76cf85e805fa9ce27ee89fc9d8933a5c668ac7a671d0ebfd712f7a8fe237b3e00c4946fdf834ed6edfca1bc69c458cfb3a6911b4d62b0c SHA512 328efe910f0593115a64a4cb37f39413364bceadfa9ee16fc2dc94362139b7c2eb890f1975aa12f3b27b4a1037c272816a83df778fc2f8abb7decd0de8238eea
diff --git a/trinity-apps/kbibtex/kbibtex-14.1.2.ebuild b/trinity-apps/kbibtex/kbibtex-14.1.2.ebuild
new file mode 100644
index 00000000..0f5cdacf
--- /dev/null
+++ b/trinity-apps/kbibtex/kbibtex-14.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de fr it pl ru"
+TRINITY_MODULE_TYPE="applications/office"
+inherit trinity-base-2
+
+DESCRIPTION="Bibliography editor for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="
+ dev-libs/libxslt
+ dev-libs/yaz
+ virtual/tex-base"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html
+ dev-tex/latex2rtf
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}