summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kiosktool
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kiosktool')
-rw-r--r--trinity-apps/kiosktool/Manifest1
-rw-r--r--trinity-apps/kiosktool/kiosktool-14.1.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/trinity-apps/kiosktool/Manifest b/trinity-apps/kiosktool/Manifest
index 9274acd6..c4d6528b 100644
--- a/trinity-apps/kiosktool/Manifest
+++ b/trinity-apps/kiosktool/Manifest
@@ -1 +1,2 @@
DIST kiosktool-trinity-14.1.1.tar.xz 269916 BLAKE2B 36413ab11dac53693ad59e02bf0046a1b2dc9a18ed48a59b73e1867f218f9448918b1c3017a48ce6ddbf1dbad6118bc973e397ca04e3254a22afa1a1d7648753 SHA512 5ed83d7d24a921fd03c758c6222406a48119ac49c2d881a758f01c43ac0c22ff23498f3a9c0ae934b87e197023eb41b8660f52780884458ed8b7139d514075d5
+DIST kiosktool-trinity-14.1.2.tar.xz 270040 BLAKE2B a819ef932a136304c14d820ae84e0908b7dd8f8a274eb4ac99a3cd9c74b6a8a7bcdcf352c0ed7279b346eb04e8f02e996218b2bc91efe18897670a543685c55a SHA512 050ebc97b19171f6011601e7abd7e2375c9218684eb06d9ebe00eac5e3f2bce1314b1ec9f3904cf2852e76971725cb51a4504e68231ef1f985640d1209372dbb
diff --git a/trinity-apps/kiosktool/kiosktool-14.1.2.ebuild b/trinity-apps/kiosktool/kiosktool-14.1.2.ebuild
new file mode 100644
index 00000000..96e77da1
--- /dev/null
+++ b/trinity-apps/kiosktool/kiosktool-14.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bg br ca cs cy da de en_GB es et fr ga is
+ it lt mt nl pt pt_BR ro ru sr sr@Latn sv ta tr"
+TRINITY_MODULE_TYPE="applications/settings"
+inherit trinity-base-2
+
+DESCRIPTION="Tool to configure the TDE kiosk framework "
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="kcmautostart"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KCM_AUTOSTART="$(usex kcmautostart)"
+ )
+
+ trinity-base-2_src_configure
+}