summaryrefslogtreecommitdiffstats
path: root/trinity-apps/mathemagics
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/mathemagics')
-rw-r--r--trinity-apps/mathemagics/Manifest1
-rw-r--r--trinity-apps/mathemagics/mathemagics-14.1.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/trinity-apps/mathemagics/Manifest b/trinity-apps/mathemagics/Manifest
index aa01d8c2..7ab09c98 100644
--- a/trinity-apps/mathemagics/Manifest
+++ b/trinity-apps/mathemagics/Manifest
@@ -1 +1,2 @@
DIST mathemagics-trinity-14.1.1.tar.xz 32776 BLAKE2B f2090a1c895a364a3d29a10045e1e15cc1b0818ba8f7bea8dfe4bbc07eab54dd5f55601251fbd5c5fcef6ed60e82b64ee54e6ee77bda2341978224fa52cb36e6 SHA512 351ea8950d10e74321be4d771a6cc34051482b9ffe2d85ef72da12bd2b7d9b78db0956ba16c0fb4b97018a113f60117e9d676fca679c5d2d33faad78db27c2a7
+DIST mathemagics-trinity-14.1.2.tar.xz 32796 BLAKE2B c222ebc6b1c262f86753b3d9e65f67144d4cbd24270188ee1367009ce4d18fea94f406b82de4be4b4137453aa6e483ddb7340fb57b4c5e1b41635e813bebb82b SHA512 772aea01b058dcb77ba2885225312122424bf6b40f3b43a52a20a180bd91c4d3c2cf4195a3c87117f91eb83d655dbe9f7ad694056f9695b2be994636b29c63ca
diff --git a/trinity-apps/mathemagics/mathemagics-14.1.2.ebuild b/trinity-apps/mathemagics/mathemagics-14.1.2.ebuild
new file mode 100644
index 00000000..0f01a280
--- /dev/null
+++ b/trinity-apps/mathemagics/mathemagics-14.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="af az bg bs ca cs da de el es et eu fi fr he hr hu is it ja \
+ lt lv mt nl nn pl pt_BR pt ro ru sk sl sr@Latn sr sv ta th \
+ tr uk wa xh zh_CN zh_TW zu"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Mathemagics is a RPN Calculator"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}