summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/development/piklab/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-05-07 19:02:31 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-05-10 10:25:45 +0900
commit61f83f1471dc6c855930195172131f6531b0f2a1 (patch)
treeb792219c54e9814634f47ff288f9beb775677f71 /ubuntu/_base/applications/development/piklab/debian/rules
parentc6d21f1119dd7eb5a1395a8d4640f837223f1ea3 (diff)
downloadtde-packaging-61f83f1471dc6c855930195172131f6531b0f2a1.tar.gz
tde-packaging-61f83f1471dc6c855930195172131f6531b0f2a1.zip
DEB piklab: switch to cmake building system
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 81ae412a67476f0c72cdddd2b26385304f26be18)
Diffstat (limited to 'ubuntu/_base/applications/development/piklab/debian/rules')
-rwxr-xr-xubuntu/_base/applications/development/piklab/debian/rules21
1 files changed, 12 insertions, 9 deletions
diff --git a/ubuntu/_base/applications/development/piklab/debian/rules b/ubuntu/_base/applications/development/piklab/debian/rules
index 5b220ac67..a6797f19a 100755
--- a/ubuntu/_base/applications/development/piklab/debian/rules
+++ b/ubuntu/_base/applications/development/piklab/debian/rules
@@ -1,14 +1,17 @@
#!/usr/bin/make -f
-# Currently is not possible to build piklab with --enable-final
-DEB_BUILD_OPTIONS += noopt
-
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"