summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kkbswitch/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /ubuntu/_base/applications/kkbswitch/debian/rules
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/kkbswitch/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kkbswitch/debian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/kkbswitch/debian/rules b/ubuntu/_base/applications/kkbswitch/debian/rules
new file mode 100755
index 000000000..959036064
--- /dev/null
+++ b/ubuntu/_base/applications/kkbswitch/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
+
+binary-install/kkbswitch-trinity::
+ dh_testdir
+ # is installed into /opt/trinity/share/applications directory
+ rm debian/$(cdbs_curpkg)/opt/trinity/share/applnk/Utilities/kkbswitch.desktop
+ rmdir -p --ignore-fail-on-non-empty debian/$(cdbs_curpkg)/opt/trinity/share/applnk/Utilities/
+ # is installed in xkb-data-extra-trinity package
+ rm debian/$(cdbs_curpkg)/opt/trinity/share/X11/xkb/symbols/ru_ua
+ rmdir -p --ignore-fail-on-non-empty debian/$(cdbs_curpkg)/opt/trinity/share/X11/xkb/symbols/