summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/mathemagics/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-08-10 23:59:11 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-08-10 23:59:11 +0200
commitd6446b3057170457f9f201fe51e8c63b87dda09c (patch)
treeb588796df2d0fbe9a74692f73e43ac95bf3816bb /ubuntu/_base/applications/mathemagics/debian/rules
parent9d01b57af3673cc0e594a74fe0c12a4d3d9a59a3 (diff)
downloadtde-packaging-d6446b3057170457f9f201fe51e8c63b87dda09c.tar.gz
tde-packaging-d6446b3057170457f9f201fe51e8c63b87dda09c.zip
DEB mathemagics: Add packaging files.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/mathemagics/debian/rules')
-rwxr-xr-xubuntu/_base/applications/mathemagics/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/mathemagics/debian/rules b/ubuntu/_base/applications/mathemagics/debian/rules
new file mode 100755
index 000000000..18aa16b96
--- /dev/null
+++ b/ubuntu/_base/applications/mathemagics/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"