summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/misc/desktop-effects-tde/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-07-05 00:28:13 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-07-05 00:28:13 +0900
commit0cf700f49d6437ea21867ae6300c7056eadfbd97 (patch)
treedec8bff7ef4366370de0ad280d6395c363ce1f3f /ubuntu/_base/applications/misc/desktop-effects-tde/debian/rules
parente52d0aefda74071dece63a038079503cdc2cc905 (diff)
downloadtde-packaging-0cf700f49d6437ea21867ae6300c7056eadfbd97.tar.gz
tde-packaging-0cf700f49d6437ea21867ae6300c7056eadfbd97.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/misc/desktop-effects-tde/debian/rules')
-rwxr-xr-xubuntu/_base/applications/misc/desktop-effects-tde/debian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/misc/desktop-effects-tde/debian/rules b/ubuntu/_base/applications/misc/desktop-effects-tde/debian/rules
new file mode 100755
index 000000000..eef8add16
--- /dev/null
+++ b/ubuntu/_base/applications/misc/desktop-effects-tde/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+binary-install/desktop-effects-tde-trinity::
+ ${DH_PYTHON2} -pdesktop-effects-tde-trinity