summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/system/xdg-desktop-portals-tde/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-10-06 13:00:59 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-10-08 21:10:35 +0900
commit5126a5692a0cf15963410b13daa9999cdee25031 (patch)
tree8b7394bd571c9bf9e5be7f5efbfd5c1d46db7a49 /ubuntu/_base/applications/system/xdg-desktop-portals-tde/debian/rules
parentb90756ca8525db433155dd804e4ab29c5b00e931 (diff)
downloadtde-packaging-5126a5692a0cf15963410b13daa9999cdee25031.tar.gz
tde-packaging-5126a5692a0cf15963410b13daa9999cdee25031.zip
DEB: add xdg-desktop-portal-tde packaging files
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/system/xdg-desktop-portals-tde/debian/rules')
-rwxr-xr-xubuntu/_base/applications/system/xdg-desktop-portals-tde/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/system/xdg-desktop-portals-tde/debian/rules b/ubuntu/_base/applications/system/xdg-desktop-portals-tde/debian/rules
new file mode 100755
index 000000000..5a0da42af
--- /dev/null
+++ b/ubuntu/_base/applications/system/xdg-desktop-portals-tde/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"