summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/pytqt/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-01-25 13:31:53 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-01-31 20:43:39 +0900
commit598ef9e753142bb4ddcc279d4870996a4d130e90 (patch)
treedf90639a8dfd0bf79f66b0ce2feee83775dd8b8e /ubuntu/_base/dependencies/pytqt/debian/rules
parent67eb46f07f21925e5451398a733b47a6e51e33a4 (diff)
downloadtde-packaging-598ef9e753142bb4ddcc279d4870996a4d130e90.tar.gz
tde-packaging-598ef9e753142bb4ddcc279d4870996a4d130e90.zip
DEB pytqt: add support for python 3.12
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 72f1328d206e603f47a6afc3085e483474189c48)
Diffstat (limited to 'ubuntu/_base/dependencies/pytqt/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/pytqt/debian/rules11
1 files changed, 7 insertions, 4 deletions
diff --git a/ubuntu/_base/dependencies/pytqt/debian/rules b/ubuntu/_base/dependencies/pytqt/debian/rules
index b070fbdf1..532bf34bd 100755
--- a/ubuntu/_base/dependencies/pytqt/debian/rules
+++ b/ubuntu/_base/dependencies/pytqt/debian/rules
@@ -97,12 +97,15 @@ install-indep: configure
dh_testroot
dh_clean -k -i
dh_installdirs -i
- for version in ${PYTHONS}; do\
- pylib=$$(python$$version -c 'from distutils import sysconfig; print (sysconfig.get_python_lib())')/PyTQt;\
- mkdir -p debian/pytqt-dev/$$pylib;\
- install -m 644 -o root -g root build-$$version/pytqtconfig.py debian/pytqt-dev/$$pylib;\
+ for version in ${PYTHONS}; do \
+ pylibdev=debian/pytqt-dev/$$(python$$version -c "import sysconfig; print(sysconfig.get_path('platstdlib'))")/dist-packages/PyTQt;\
+ mkdir -p $$pylibdev;\
+ install -m 644 -o root -g root build-$$version/pytqtconfig.py $$pylibdev/pytqtconfig_nd.py; \
+ install -m 644 -o root -g root dbg-build-$$version/pytqtconfig.py $$pylibdev/pytqtconfig_d.py; \
done
dh_install -i
+ mkdir -p debian/pytqt-dev/usr/lib/python3/dist-packages/PyTQt
+ install -m 644 -o root -g root debian/pytqtconfig_py3.py debian/pytqt-dev/usr/lib/python3/dist-packages/PyTQt/pytqtconfig.py
install-arch: build
dh_testdir