summaryrefslogtreecommitdiffstats
path: root/redhat/applications/office/tellico/tellico.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/office/tellico/tellico.spec')
-rw-r--r--redhat/applications/office/tellico/tellico.spec32
1 files changed, 23 insertions, 9 deletions
diff --git a/redhat/applications/office/tellico/tellico.spec b/redhat/applications/office/tellico/tellico.spec
index ee92c8f4b..e51a25226 100644
--- a/redhat/applications/office/tellico/tellico.spec
+++ b/redhat/applications/office/tellico/tellico.spec
@@ -22,7 +22,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg tellico
%define tde_prefix /opt/trinity
@@ -110,7 +110,12 @@ BuildRequires: %{_lib}yaz-devel
BuildRequires: libxml2-devel
# XSLT support
-BuildRequires: libxslt-devel
+%if 0%{?mdkver}
+BuildRequires: %{_lib}xslt-devel
+%else
+BuildRequires: libxslt-devel
+%endif
+
%if 0%{?rhel} == 4
# a bogus dep in libexslt.la file from EL-4 (WONTFIX bug http://bugzilla.redhat.com/142241)
BuildRequires: libgcrypt-devel
@@ -145,13 +150,26 @@ BuildRequires: gamin-devel
%endif
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# ATTR support
-BuildRequires: libattr-devel
+%if 0%{?mgaversion} || 0%{?mdkversion}
+%define libattr_devel %{_lib}attr-devel
+%else
+%define libattr_devel libattr-devel
+%endif
+BuildRequires: %{libattr_devel}
# PYTHON support
%global python python3
@@ -220,14 +238,10 @@ documentation.
%{tde_datadir}/apps/tellico/*.xml
%{tde_datadir}/apps/tellico/*.png
%{tde_datadir}/apps/tellico/entry-templates
-%if 0%{?rhel} == 7 || 0%{?suse_version}
%{tde_datadir}/apps/tellico/*.py*
-%if 0%{?rhel} == 7
+%if 0%{?rhel} == 7 || 0%{?mgaversion} == 8
%{tde_datadir}/apps/tellico/__pycache__/
%endif
-%else
-%pycached %{tde_datadir}/apps/tellico/*.py
-%endif
%{tde_datadir}/apps/tellico/pics
%{tde_datadir}/apps/tellico/report-templates
%{tde_datadir}/apps/tellico/tellico.dtd
@@ -305,7 +319,7 @@ unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi