summaryrefslogtreecommitdiffstats
path: root/client/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/config/CMakeLists.txt')
-rw-r--r--client/config/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/client/config/CMakeLists.txt b/client/config/CMakeLists.txt
new file mode 100644
index 0000000..9a37989
--- /dev/null
+++ b/client/config/CMakeLists.txt
@@ -0,0 +1,40 @@
+################################################################################
+# Polyester - widget style and twin decoration aimed to be a good balance #
+# between eye candy and simplicity #
+# #
+# This file is released under the GNU GPL version 3 or later. #
+# Improvements and feedback are welcome! #
+################################################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+### buttons.h ##################################################################
+add_custom_target(buttons.h
+ COMMAND ${CMAKE_COMMAND} -E create-buttons.sh
+)
+
+### twin_polyester_config (kpart) ##############################################
+tde_add_kpart(twin_polyester_config
+ AUTOMOC
+
+ SOURCES
+ configdialog.ui
+ polyesterconfig.cc
+
+ LINK
+ tdecore-shared
+ tdeui-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)