summaryrefslogtreecommitdiffstats
path: root/systemsettings/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-12 18:38:11 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-12 18:38:11 +0000
commit686c40f4da78216e8f31dcc6cb08a763c2b207c0 (patch)
tree75e75535eb77b5fb3ba0105bae9e3307e0efcc3e /systemsettings/Makefile.am
downloadtde-systemsettings-686c40f4da78216e8f31dcc6cb08a763c2b207c0.tar.gz
tde-systemsettings-686c40f4da78216e8f31dcc6cb08a763c2b207c0.zip
Added KDE3 version of kde-systemsettings
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kde-systemsettings@1089234 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'systemsettings/Makefile.am')
-rw-r--r--systemsettings/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/systemsettings/Makefile.am b/systemsettings/Makefile.am
new file mode 100644
index 0000000..afe2ec3
--- /dev/null
+++ b/systemsettings/Makefile.am
@@ -0,0 +1,45 @@
+#
+# Copyright (c) 2005 Benjamin Meyer <ben+systempreferences@meyerhome.net>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Steet, Fifth Floor, Boston, MA 02110-1301, USA.
+#
+
+AM_CPPFLAGS= $(all_includes)
+METASOURCES = AUTO
+
+SUBDIRS = . menu
+
+bin_PROGRAMS = systemsettings
+
+systemsettings_SOURCES = kcmodulemenu.cpp kcmsearch.cpp kcmultiwidget.cpp main.cpp mainwindow.cpp moduleiconitem.cpp modulesview.cpp kcscrollview.cpp
+
+EXTRA_DIST = kcmodulemenu.h kcmultiwidget.h moduleiconitem.h version.h kcmsearch.h mainwindow.h modulesview.h kcscrollview.h
+
+systemsettings_LDADD = $(LIB_KDEUI) $(LIB_KUTILS)
+systemsettings_LDFLAGS = $(all_libraries) -module -avoid-version
+
+appdata_DATA = systemsettingsui.rc
+appdatadir = $(kde_datadir)/systemsettings
+
+xdg_apps_DATA = systemsettings.desktop
+
+KDE_ICON=AUTO
+
+# KDE4 will have this by default
+conf_DATA = systemsettingsrc
+confdir = $(kde_confdir)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/systemsettings.pot