summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/desktop/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:00:38 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:00:38 -0600
commit4bc3dcd8cbc23e1470e121e25a83d57c22e61b26 (patch)
tree7d379893635b06789888944241a976a4f2b440ab /tdefile-plugins/desktop/Makefile.am
parent08a66075486dc740840cfb817bf0ca301c6f0385 (diff)
downloadtdeaddons-4bc3dcd8cbc23e1470e121e25a83d57c22e61b26.tar.gz
tdeaddons-4bc3dcd8cbc23e1470e121e25a83d57c22e61b26.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/desktop/Makefile.am')
-rw-r--r--tdefile-plugins/desktop/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/desktop/Makefile.am b/tdefile-plugins/desktop/Makefile.am
new file mode 100644
index 0000000..e8315ad
--- /dev/null
+++ b/tdefile-plugins/desktop/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for .desktop file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_desktop.h
+
+kde_module_LTLIBRARIES = tdefile_desktop.la
+
+tdefile_desktop_la_SOURCES = tdefile_desktop.cpp
+tdefile_desktop_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_desktop_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdefile_desktop.pot
+
+services_DATA = tdefile_desktop.desktop
+servicesdir = $(kde_servicesdir)