summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2023-03-09 05:33:19 +0100
committerSlávek Banko <slavek.banko@axis.cz>2023-03-09 05:52:54 +0100
commit66c9d2a5920b30474b595603a79915d2be38cdbe (patch)
treec896bdcef6cba137863cebb6106c62a9fd01c6ca /CMakeLists.txt
parent0c8df48682481faa5249ab010e09d67af08e6457 (diff)
downloadtdebluez-66c9d2a5920b30474b595603a79915d2be38cdbe.tar.gz
tdebluez-66c9d2a5920b30474b595603a79915d2be38cdbe.zip
Added CMakeL10n rules.
Added template for translations. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83c8f5b..a63c93e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,7 @@ option( BUILD_ALL "Build all" OFF )
option( BUILD_LIBTDEBLUEZ "Build libtdebluez" ${BUILD_ALL} )
option( BUILD_TDEIOSLAVE "Build tdeioslave" ${BUILD_ALL} )
option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks ##########################
@@ -95,6 +96,7 @@ add_subdirectory( src/tdebluezauth )
##### other data ################################
tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files #####################