summaryrefslogtreecommitdiffstats
path: root/libtdeedu/extdate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libtdeedu/extdate/Makefile.am')
-rw-r--r--libtdeedu/extdate/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/libtdeedu/extdate/Makefile.am b/libtdeedu/extdate/Makefile.am
new file mode 100644
index 00000000..f02c4924
--- /dev/null
+++ b/libtdeedu/extdate/Makefile.am
@@ -0,0 +1,21 @@
+check_PROGRAMS = test_extdate test_extdatepicker
+
+INCLUDES= $(all_includes)
+
+lib_LTLIBRARIES = libextdate.la
+
+libextdate_la_SOURCES = extdatetime.cpp extcalendarsystem.cpp extcalendarsystemgregorian.cpp extdatetbl.cpp extdatepicker.cpp extdatetimeedit.cpp extdatewidget.cpp
+
+libextdate_la_LDFLAGS = $(all_libraries) -no-undefined -version-info 3:0:2
+libextdate_la_LIBADD = $(LIB_TDEUI)
+
+test_extdate_SOURCES = test_extdate.cc
+test_extdate_LDADD = libextdate.la
+test_extdate_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor
+
+test_extdatepicker_SOURCES = testwidget.cpp main.cpp
+test_extdatepicker_LDADD = libextdate.la
+test_extdatepicker_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor
+
+METASOURCES = AUTO
+