summaryrefslogtreecommitdiffstats
path: root/kfax/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit47d455dd55be855e4cc691c32f687f723d9247ee (patch)
tree52e236aaa2576bdb3840ebede26619692fed6d7d /kfax/Makefile.am
downloadtdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.tar.gz
tdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfax/Makefile.am')
-rw-r--r--kfax/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/kfax/Makefile.am b/kfax/Makefile.am
new file mode 100644
index 00000000..fd3e478c
--- /dev/null
+++ b/kfax/Makefile.am
@@ -0,0 +1,32 @@
+AM_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+LDADD = $(LIB_KFILE) $(LIB_KDEPRINT) -lm
+INCLUDES = $(all_includes)
+
+####### Files
+noinst_HEADERS = kfax.h faxexpand.h options.h
+
+kfax_SOURCES = options.cpp kfax.cpp faxexpand.cpp faxinit.cpp faxinput.cpp \
+ viewfax.cpp kfax_printsettings.cpp
+
+METASOURCES = AUTO
+
+bin_PROGRAMS = kfax
+
+xdg_apps_DATA = kfax.desktop
+
+picsdir = $(kde_datadir)/kfax/pics
+pics_DATA = kfax.tif kfaxlogo.xpm
+
+rcdir = $(kde_datadir)/kfax
+rc_DATA = kfaxui.rc
+
+KDE_ICON = kfax
+
+EXTRA_DIST = $(xdg_apps_DATA) $(pics_DATA)
+
+messages: rc.cpp
+ $(XGETTEXT) $(kfax_SOURCES) -o $(podir)/kfax.pot
+
+####### Explicit dependencies
+
+