summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt')
-rw-r--r--kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt b/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt
deleted file mode 100644
index 42d50a80..00000000
--- a/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Calvin Morrison
-# mutantturkey@gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-project( libpoppler-tqt )
-
-##### configure checks ##########################
-
-include( ConfigureChecks.cmake )
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
- ${CMAKE_SOURCE_DIR}/kfile-plugins/dependencies/poppler-tqt
- ${POPPLER_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-##### pc files ##################################
-
-configure_file( poppler-tqt.pc.cmake poppler-tqt.pc @ONLY )
-
-install( FILES ${CMAKE_CURRENT_BINARY_DIR}/poppler-tqt.pc DESTINATION ${PKGCONFIG_INSTALL_DIR} )
-
-##### headers ###################################
-
-install( FILES
- poppler-qt.h poppler-page-transition.h poppler-link-qt3.h
- DESTINATION ${INCLUDE_INSTALL_DIR} )
-
-##### poppler-tqt (shared) ############################
-
-tde_add_library( poppler-tqt SHARED AUTOMOC
- SOURCES
- poppler-document.cc poppler-fontinfo.cc
- poppler-link.cc poppler-page.cc
- poppler-page-transition.cc poppler-page-transition-private.h
- poppler-private.cc poppler-private.h
- VERSION 0.0.0
- LINK poppler ${TQT_LIBRARIES}
- DESTINATION ${LIB_INSTALL_DIR}
-)