summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/ps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/ps/Makefile.am')
-rw-r--r--kfile-plugins/ps/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/kfile-plugins/ps/Makefile.am b/kfile-plugins/ps/Makefile.am
new file mode 100644
index 00000000..9c5b20a3
--- /dev/null
+++ b/kfile-plugins/ps/Makefile.am
@@ -0,0 +1,26 @@
+## Makefile.am for the ps file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir)/kghostview $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_ps.h gscreator.h
+
+kde_module_LTLIBRARIES = kfile_ps.la gsthumbnail.la
+
+kfile_ps_la_SOURCES = kfile_ps.cpp
+kfile_ps_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_ps_la_LIBADD = $(LIB_KIO) ../../kghostview/libdscparse.la
+
+gsthumbnail_la_SOURCES = gscreator.cpp
+gsthumbnail_la_LIBADD = $(LIB_KDECORE) ../../kghostview/libdscparse.la
+gsthumbnail_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kfile_ps.pot
+
+services_DATA = kfile_ps.desktop gsthumbnail.desktop
+servicesdir = $(kde_servicesdir)