summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-08-25 22:09:31 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-08-25 22:09:31 +0900
commit1fea9ad19418595646770b7179972b682a074683 (patch)
tree6186b9203cf48985a651bc6c61a7498552b76587 /CMakeLists.txt
downloadtdeio-gopher-1fea9ad19418595646770b7179972b682a074683.tar.gz
tdeio-gopher-1fea9ad19418595646770b7179972b682a074683.zip
Initial import of kio-gopher 0.1.4 source code.
Copyright (C) 2003-2008 by Albert Astals Cid (aacid@kde.org). The code is licenced under GPL version 2 as indicated in the source code comments and in the COPYING file. The code does not compile under TDE. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..72706c8
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+find_package(KDE4 REQUIRED)
+include(KDE4Defaults)
+add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
+include_directories(${KDE4_INCLUDES})
+
+add_subdirectory(doc)
+
+set(kio_man_PART_SRCS kio_gopher.cpp)
+
+kde4_add_plugin(kio_gopher ${kio_man_PART_SRCS})
+
+target_link_libraries(kio_gopher ${KDE4_KIO_LIBS})
+
+install(TARGETS kio_gopher DESTINATION ${PLUGIN_INSTALL_DIR})
+
+install(FILES gopher.protocol DESTINATION ${SERVICES_INSTALL_DIR})
+
+find_package(Msgfmt REQUIRED)
+find_package(Gettext REQUIRED)
+add_subdirectory( po )
+add_subdirectory( doc-translations )