summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt36
1 files changed, 19 insertions, 17 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 65045d6..bc8369e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,28 +1,26 @@
-
-
-
-#set(tdeio_man_PART_SRCS tdeio_gopher.cpp)
-
-#kde4_add_plugin(tdeio_gopher ${tdeio_man_PART_SRCS})
-
-
-#find_package(Msgfmt REQUIRED)
-#find_package(Gettext REQUIRED)
-#add_subdirectory( po )
-#add_subdirectory( doc-translations )
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/src
+ ${CMAKE_SOURCE_DIR}/src
)
link_directories(
${TQT_LIBRARY_DIRS}
)
-#####add_subdirectory(doc)
##### other data ################################
@@ -33,8 +31,12 @@ install( FILES gopher.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
set( target tdeio_gopher )
+set( ${target}_SRCS
+ tdeio_gopher.cpp
+)
+
tde_add_kpart( ${target} AUTOMOC
- SOURCES tdeio_gopher.cpp
+ SOURCES ${${target}_SRCS}
LINK tdeio-shared
DESTINATION ${PLUGIN_INSTALL_DIR}
)