summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-01-12 13:44:52 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-12 17:36:13 +0100
commitf938ddefb96507d85e76252b1824772172ee0a19 (patch)
tree1998b070c49b3808225c03a0bc246c7591d4b8a1 /src/CMakeLists.txt
parent76edb535e24936fb4d5ff62344f577d95330ee9f (diff)
downloadtdeio-sword-f938ddefb96507d85e76252b1824772172ee0a19.tar.gz
tdeio-sword-f938ddefb96507d85e76252b1824772172ee0a19.zip
conversion to the cmake building system
Signed-off-by: gregory guy <g-gregory@gmx.fr> (cherry picked from commit c582b3bf38f9d95e8af05b28a3d653e96ead5dea)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..1697ec1
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,49 @@
+add_subdirectory( data )
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${LIBSWORD_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeio_sword (kpart)
+
+tde_add_kpart( tdeio_sword AUTOMOC
+
+ SOURCES
+ tdeio_sword.cpp
+ renderer.cpp
+ ks_osishtml.cpp
+ ks_gbfhtml.cpp
+ ks_thmlhtml.cpp
+ utils.cpp
+ swordutils.cpp
+ swordoptions.cpp
+ filter.cpp
+ template.cpp
+ plainhtml.cpp
+ LINK
+ tdecore-shared
+ tdeio-shared
+ ${LIBSWORD_LIBRARY}
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES sword.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)