summaryrefslogtreecommitdiffstats
path: root/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/CMakeLists.txt')
-rw-r--r--src/tests/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
new file mode 100644
index 0000000..1a00233
--- /dev/null
+++ b/src/tests/CMakeLists.txt
@@ -0,0 +1,57 @@
+#################################################
+#
+# (C) 2016 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### define tests ##############################
+
+add_test( isbtest isbntest )
+
+add_test( latin1test latin1test )
+
+add_test( entitytest entitytest )
+
+
+##### test programs #############################
+
+tde_add_executable( isbntest AUTOMOC
+ SOURCES
+ isbntest.cpp
+ ../isbnvalidator.cpp ../upcvalidator.cpp
+ LINK
+ tdecore-shared tdeui-shared
+)
+
+tde_add_executable( latin1test AUTOMOC
+ SOURCES
+ latin1test.cpp
+ LINK
+ tdecore-shared
+)
+
+tde_add_executable( entitytest AUTOMOC
+ SOURCES
+ entitytest.cpp
+ ../tellico_utils.cpp
+ LINK
+ tdecore-shared
+)