summaryrefslogtreecommitdiffstats
path: root/src/translators/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/translators/CMakeLists.txt')
-rw-r--r--src/translators/CMakeLists.txt62
1 files changed, 62 insertions, 0 deletions
diff --git a/src/translators/CMakeLists.txt b/src/translators/CMakeLists.txt
new file mode 100644
index 0000000..459e781
--- /dev/null
+++ b/src/translators/CMakeLists.txt
@@ -0,0 +1,62 @@
+#################################################
+#
+# (C) 2016 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}/tde
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### translators (static) ######################
+
+tde_add_library( translators STATIC_PIC AUTOMOC
+ SOURCES
+ alexandriaexporter.cpp alexandriaimporter.cpp
+ amcimporter.cpp audiofileimporter.cpp bibtexexporter.cpp bibtexhandler.cpp
+ bibteximporter.cpp bibtexmlexporter.cpp bibtexmlimporter.cpp csvexporter.cpp
+ csvimporter.cpp dcimporter.cpp deliciousimporter.cpp exporter.cpp
+ filelistingimporter.cpp freedb_util.cpp freedbimporter.cpp gcfilmsexporter.cpp
+ gcfilmsimporter.cpp griffithimporter.cpp grs1importer.cpp htmlexporter.cpp libcsv.c
+ onixexporter.cpp pdfimporter.cpp pilotdbexporter.cpp referencerimporter.cpp
+ risimporter.cpp tellico_xml.cpp tellicoimporter.cpp tellicosaximporter.cpp
+ tellicoxmlexporter.cpp tellicoxmlhandler.cpp tellicozipexporter.cpp textimporter.cpp
+ xmlimporter.cpp xmlstatehandler.cpp xsltexporter.cpp xslthandler.cpp xsltimporter.cpp
+ dataimporter.cpp importer.cpp
+ LINK
+ gui-static
+)
+
+
+##### other data ################################
+install(
+ FILES bibtex-translation.xml
+ DESTINATION ${DATA_INSTALL_DIR}/${CMAKE_PROJECT_NAME}
+)
+install(
+ PROGRAMS griffith2tellico.py
+ DESTINATION ${DATA_INSTALL_DIR}/${CMAKE_PROJECT_NAME}
+)
+
+
+##### directories ###############################
+
+if( NOT WITH_LIBBTPARSE )
+ add_subdirectory( btparse )
+endif( )
+add_subdirectory( pilotdb )