summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <mavridisf@gmail.com>2021-06-26 14:07:19 +0300
committerMavridis Philippe <mavridisf@gmail.com>2021-06-26 16:02:47 +0300
commiteea7c57cb1ede44c728762bddcea114ae3711ba4 (patch)
treefa97723d6014f62e6b3b61ae89971def819635b4 /translations/messages/CMakeLists.txt
parent2b4b28b13e426332661ef580ac12cae2227bed55 (diff)
downloadtwin-style-suse2-eea7c57cb1ede44c728762bddcea114ae3711ba4.tar.gz
twin-style-suse2-eea7c57cb1ede44c728762bddcea114ae3711ba4.zip
Added CMake l10n rules
Signed-off-by: Mavridis Philippe <mavridisf@gmail.com>
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )