summaryrefslogtreecommitdiffstats
path: root/lib/libtdekrb/src/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-06-23 17:23:49 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-06-23 17:23:49 -0500
commit8dcfe72c396a6f0c4bafd2ed23ba52a475154ef2 (patch)
treea0a77ec1d7d7cd826e1f2ba92ea4f96351bae5e3 /lib/libtdekrb/src/Makefile.am
parentb48b26b86975d2166a4da7fc41086facefb3c4f2 (diff)
downloadulab-8dcfe72c396a6f0c4bafd2ed23ba52a475154ef2.tar.gz
ulab-8dcfe72c396a6f0c4bafd2ed23ba52a475154ef2.zip
Fix a number of crashes and generally clean up the code
Diffstat (limited to 'lib/libtdekrb/src/Makefile.am')
-rw-r--r--lib/libtdekrb/src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/libtdekrb/src/Makefile.am b/lib/libtdekrb/src/Makefile.am
index b0b10cf..9cbe92e 100644
--- a/lib/libtdekrb/src/Makefile.am
+++ b/lib/libtdekrb/src/Makefile.am
@@ -1,5 +1,6 @@
-INCLUDES = $(all_includes) -I/usr/include/sasl
-METASOURCES = AUTO
+INCLUDES = $(all_includes) -I/usr/include/sasl
+KDE_CXXFLAGS = $(USE_EXCEPTIONS)
+METASOURCES = AUTO
# Create a shared library file
lib_LTLIBRARIES = libtdekrbsocket.la
@@ -8,4 +9,4 @@ include_HEADERS = tdekrbclientsocket.h tdekrbserversocket.h
libtdekrbsocket_la_SOURCES = tdekrbclientsocket.cpp tdekrbserversocket.cpp
libtdekrbsocket_la_LIBADD = -lkio $(LIB_TDEUI) -lsasl2
-libtdekrbsocket_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries) \ No newline at end of file
+libtdekrbsocket_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)