summaryrefslogtreecommitdiffstats
path: root/servers/auth_server_lin/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-06-14 16:39:24 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-06-14 16:39:24 -0500
commit0feee8a20585a2c713e4ab5a0060fc37480b7cb1 (patch)
tree40d862b8517a68465855ce7b5a0cc3070cc99edc /servers/auth_server_lin/debian/rules
parentfde9147dfb80f0cbc42191a6cf713189db50926d (diff)
downloadulab-0feee8a20585a2c713e4ab5a0060fc37480b7cb1.tar.gz
ulab-0feee8a20585a2c713e4ab5a0060fc37480b7cb1.zip
Add new authserver skeleton tree
Diffstat (limited to 'servers/auth_server_lin/debian/rules')
-rwxr-xr-xservers/auth_server_lin/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/servers/auth_server_lin/debian/rules b/servers/auth_server_lin/debian/rules
new file mode 100755
index 0000000..242fb2c
--- /dev/null
+++ b/servers/auth_server_lin/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap