summaryrefslogtreecommitdiffstats
path: root/lib/ffts/debian
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ffts/debian')
-rwxr-xr-xlib/ffts/debian/rules20
1 files changed, 14 insertions, 6 deletions
diff --git a/lib/ffts/debian/rules b/lib/ffts/debian/rules
index 968c6ef..ff19c8d 100755
--- a/lib/ffts/debian/rules
+++ b/lib/ffts/debian/rules
@@ -18,16 +18,24 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+# Generic architecture default
+cdbs_configure_flags := --enable-single --disable-dynamic-code --enable-shared --disable-rpath
+
ifneq (,$(findstring x86_64-,$(DEB_BUILD_GNU_TYPE)))
cdbs_configure_flags := --enable-single --enable-sse --enable-shared --disable-rpath
-else ifneq (,$(findstring arm-,$(DEB_BUILD_GNU_TYPE)))
-ifneq(,$(findstring armhf,$(DEB_HOST_ARCH)))
+endif
+
+ifneq (,$(findstring powerpc-,$(DEB_BUILD_GNU_TYPE)))
+ cdbs_configure_flags := --enable-single --disable-dynamic-code --enable-shared --disable-rpath
+endif
+
+ifneq (,$(findstring arm-,$(DEB_BUILD_GNU_TYPE)))
+ ifneq(,$(findstring armhf,$(DEB_HOST_ARCH)))
cdbs_configure_flags := --enable-single --enable-neon --float_abi=hard --enable-shared --disable-rpath
-else ifneq (,$(findstring aarch64-,$(DEB_BUILD_GNU_TYPE)))
+ endif
+ ifneq (,$(findstring aarch64-,$(DEB_BUILD_GNU_TYPE)))
cdbs_configure_flags := --enable-single --enable-neon --float_abi=hard --enable-shared --disable-rpath
-else
- cdbs_configure_flags := --enable-single --enable-shared --disable-rpath
-endif
+ endif
post-patches:: debian/stamp-bootstrap