summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-27 18:47:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-27 18:47:15 -0600
commitfbfc28021ca0dee1dfb0d84e886e4ee9d8af05a3 (patch)
tree1a83bcb9172c3f095889c79129abf522e4be240c /po/CMakeLists.txt
parenteaad965ca890c7c237c09e8dac5bed6e111adfb6 (diff)
downloadwlassistant-fbfc28021ca0dee1dfb0d84e886e4ee9d8af05a3.tar.gz
wlassistant-fbfc28021ca0dee1dfb0d84e886e4ee9d8af05a3.zip
Initial attempt at using the standard CMake system
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..77a6378
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,17 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} wlassistant.po )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} PATH )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )