summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..3ebb7c2
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,39 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/src
+ ${CMAKE_SOURCE_DIR}/src
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES wlassistant.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+##### wlassistant(executable) ###################
+
+tde_add_executable( wlassistant
+ SOURCES main.cpp netlistviewitem.cpp
+ ui_NetParamsEdit.ui ui_netparamsedit.cpp
+ ui_NetParamsWizard.ui ui_netparamswizard.cpp
+ ui_main.ui waconfig.cpp watools.cpp wlassistant.cpp
+ LINK tdecore-shared tdeui-shared iw-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)