summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIdan Freiberg <speidy@gmail.com>2017-01-23 08:22:29 +0200
committerGitHub <noreply@github.com>2017-01-23 08:22:29 +0200
commit92d9f2e37e62e1354266d599dc37d6f9fe557351 (patch)
tree6846966e24aa5ba350d7c2693be3eb64a1843d1a /configure.ac
parentdbfea35662f6ada7c31f041aac73cadabdd46018 (diff)
parent250bb610258fe762871aa2c479a1e5f485e88b89 (diff)
downloadxrdp-proprietary-92d9f2e37e62e1354266d599dc37d6f9fe557351.tar.gz
xrdp-proprietary-92d9f2e37e62e1354266d599dc37d6f9fe557351.zip
Merge pull request #627 from proski/openssl
Check for openssl binary in configure, don't fail if not found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac07b532..c7b1d41e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,6 +145,10 @@ AC_SUBST(DLOPEN_LIBS)
PKG_CHECK_MODULES([OPENSSL], [openssl >= 0], [],
[AC_MSG_ERROR([please install libssl-dev or openssl-devel])])
+# look for openssl binary
+OPENSSL_BIN=`$PKG_CONFIG --variable=exec_prefix openssl`/bin
+AC_PATH_PROGS([OPENSSL], [openssl], [:], [$OPENSSL_BIN:$PATH])
+
# checking for pam variation
# Linux-PAM is used in Linux systems
# OpenPAM is used by FreeBSD, NetBSD, DragonFly BSD and OS X