summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Sorg <jay.sorg@gmail.com>2012-11-02 23:10:36 -0700
committerJay Sorg <jay.sorg@gmail.com>2012-11-02 23:10:36 -0700
commitcdb039080f47ee31e97dcb88591e8194e03f3878 (patch)
treee3a69c2cd301d7b326a3abec7256a8ddc6651be7 /configure.ac
parent02d52444c3747b5a5066788076d8f9c1e9df2440 (diff)
downloadxrdp-proprietary-cdb039080f47ee31e97dcb88591e8194e03f3878.tar.gz
xrdp-proprietary-cdb039080f47ee31e97dcb88591e8194e03f3878.zip
chansrv: added --enable-fuse option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7b437e2..b29ce965 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,10 @@ AC_ARG_ENABLE(simplesound, AS_HELP_STRING([--enable-simplesound],
[Build simple pulse audio interface (default: no)]),
[simplesound=true], [simplesound=false])
AM_CONDITIONAL(XRDP_SIMPLESOUND, [test x$simplesound = xtrue])
+AC_ARG_ENABLE(fuse, AS_HELP_STRING([--enable-fuse],
+ [Build fuse(clipboard file / drive redir) (default: no)]),
+ [fuse=true], [fuse=false])
+AM_CONDITIONAL(XRDP_FUSE, [test x$fuse = xtrue])
AM_CONDITIONAL(GOT_PREFIX, test "x${prefix}" != "xNONE"])
@@ -70,6 +74,14 @@ then
[AC_MSG_ERROR([please install libjpeg-dev or libjpeg-devel])])
fi
+# checking for fuse
+if ! test -z "$enable_fuse"
+then
+ AC_CHECK_HEADER([fuse.h], [],
+ [AC_MSG_ERROR([please install libfuse-dev or fuse-devel])],
+ [#define _FILE_OFFSET_BITS 64])
+fi
+
# checking for libpulse libpulse-simple
if ! test -z "$enable_simplesound"
then