summaryrefslogtreecommitdiffstats
path: root/docs/man/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2017-03-14 21:45:50 -0700
committerjsorg71 <jay.sorg@gmail.com>2017-03-17 22:25:05 -0700
commit58c9cb43e9e83a6f5cc8a13cd84aa67cce8cacd5 (patch)
tree4440da8a15401e221175c4b6d3df6c44253e3f2e /docs/man/Makefile.am
parentfc2572f60b574cf5bc45f1c7b58698681f39ac50 (diff)
downloadxrdp-proprietary-58c9cb43e9e83a6f5cc8a13cd84aa67cce8cacd5.tar.gz
xrdp-proprietary-58c9cb43e9e83a6f5cc8a13cd84aa67cce8cacd5.zip
Make socket directory configurable, don't hardcode /tmp/.xrdp
Use XRDP_SOCKET_PATH in file_loc.h Don't define any non-socket paths in file_loc.h, they should come from the makefiles. Define all paths unconditionally, they should not be defined elsewhere. Pass XRDP_SOCKET_PATH as environment variable to the backends.
Diffstat (limited to 'docs/man/Makefile.am')
-rw-r--r--docs/man/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/docs/man/Makefile.am b/docs/man/Makefile.am
index 705def0c..f6e0bd5a 100644
--- a/docs/man/Makefile.am
+++ b/docs/man/Makefile.am
@@ -17,7 +17,8 @@ SUBST_VARS = sed \
-e 's|@PACKAGE_VERSION[@]|$(PACKAGE_VERSION)|g' \
-e 's|@bindir[@]|$(bindir)|g' \
-e 's|@localstatedir[@]|$(localstatedir)|g' \
- -e 's|@sysconfdir[@]|$(sysconfdir)|g'
+ -e 's|@sysconfdir[@]|$(sysconfdir)|g' \
+ -e 's|@socketdir[@]|$(socketdir)|g'
subst_verbose = $(subst_verbose_@AM_V@)
subst_verbose_ = $(subst_verbose_@AM_DEFAULT_V@)