summaryrefslogtreecommitdiffstats
path: root/instfiles/pam.d/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-12-30 20:00:46 -0800
committerPavel Roskin <plroskin@gmail.com>2017-01-15 00:57:59 -0800
commit8799bbac42f0e4ba0f878b9c0c39229bbc4863fb (patch)
treeae9003012da92c34c9ab03d3c49de3f3d86f5393 /instfiles/pam.d/Makefile.am
parent63472bb181f2bc5d4039ca9a99d355e9bed750ec (diff)
downloadxrdp-proprietary-8799bbac42f0e4ba0f878b9c0c39229bbc4863fb.tar.gz
xrdp-proprietary-8799bbac42f0e4ba0f878b9c0c39229bbc4863fb.zip
Allow PAM file selection in configure, improve autodetection, add SUSE
Use easy to understand names for config files (debian, redhat, suse, unix). Move all autodetection to a separate script.
Diffstat (limited to 'instfiles/pam.d/Makefile.am')
-rw-r--r--instfiles/pam.d/Makefile.am24
1 files changed, 9 insertions, 15 deletions
diff --git a/instfiles/pam.d/Makefile.am b/instfiles/pam.d/Makefile.am
index 3e09802b..d28a18e4 100644
--- a/instfiles/pam.d/Makefile.am
+++ b/instfiles/pam.d/Makefile.am
@@ -1,7 +1,10 @@
-EXTRA_DIST = \
- xrdp-sesman.common \
- xrdp-sesman.other \
- xrdp-sesman.password-auth
+PAM_FILES = \
+ xrdp-sesman.debian \
+ xrdp-sesman.redhat \
+ xrdp-sesman.suse \
+ xrdp-sesman.unix
+
+EXTRA_DIST = $(PAM_FILES) mkpamrules
CLEANFILES = xrdp-sesman
@@ -24,14 +27,5 @@ pamddir = $(sysconfdir)/pam.d
pamd_DATA = \
$(PAMFILE)
-xrdp-sesman:
- if test -e /etc/pam.d/password-auth; then \
- pamrules=xrdp-sesman.password-auth; \
- else \
- if test -e /etc/pam.d/common-auth; then \
- pamrules=xrdp-sesman.common; \
- else \
- pamrules=xrdp-sesman.other; \
- fi; \
- fi; \
- $(LN_S) $(srcdir)/$$pamrules $@
+xrdp-sesman: mkpamrules
+ $(srcdir)/mkpamrules $(PAM_RULES) $(srcdir) $@