summaryrefslogtreecommitdiffstats
path: root/mc/Makefile.am
diff options
context:
space:
mode:
authorvolth <volth@webmaster.ms>2017-01-04 12:54:55 +0000
committervolth <volth@webmaster.ms>2017-01-04 13:00:01 +0000
commit37b4a14b5472eaeb1650e915b7b302d1d7d1adf2 (patch)
treeded23ed187d26cee7572ac5810a0ee3c64ff25c4 /mc/Makefile.am
parentcd8b5f00309874686bca943c62d190f82666adef (diff)
downloadxrdp-proprietary-37b4a14b5472eaeb1650e915b7b302d1d7d1adf2.tar.gz
xrdp-proprietary-37b4a14b5472eaeb1650e915b7b302d1d7d1adf2.zip
fix build with --enable-xrdpdebug=yes
Diffstat (limited to 'mc/Makefile.am')
-rw-r--r--mc/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/mc/Makefile.am b/mc/Makefile.am
index e705ff0d..eebef8c3 100644
--- a/mc/Makefile.am
+++ b/mc/Makefile.am
@@ -5,6 +5,12 @@ AM_CPPFLAGS = \
-DXRDP_PID_PATH=\"${localstatedir}/run\" \
-I$(top_srcdir)/common
+if XRDP_DEBUG
+AM_CPPFLAGS += -DXRDP_DEBUG
+else
+AM_CPPFLAGS += -DXRDP_NODEBUG
+endif
+
module_LTLIBRARIES = \
libmc.la