summaryrefslogtreecommitdiffstats
path: root/neutrinordp/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-10-17 10:33:28 -0700
committerPavel Roskin <plroskin@gmail.com>2016-10-20 10:43:02 -0700
commit0422734fc77bdff2c65df14f27b0fd0400775b23 (patch)
treebe59ff10236e777ef83e5d27fe91e7933661296f /neutrinordp/Makefile.am
parent85e98d211a4cad94ebcd87c91966c8f30e4e0b9d (diff)
downloadxrdp-proprietary-0422734fc77bdff2c65df14f27b0fd0400775b23.tar.gz
xrdp-proprietary-0422734fc77bdff2c65df14f27b0fd0400775b23.zip
Merge EXTRA_DEFINES and EXTRA_INCLUDES into AM_CPPFLAGS
AM_CPPFLAGS is a documented Automake variable for C preprocessor flags that should not be overridden when compiling the package. There is no need to have two additional variables that are ultimately merged into AM_CPPFLAGS. Their names are also confusing. EXTDA_DIST is a documented Automake variable. Everything else that starts with "EXTRA" is not.
Diffstat (limited to 'neutrinordp/Makefile.am')
-rw-r--r--neutrinordp/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/neutrinordp/Makefile.am b/neutrinordp/Makefile.am
index 83504b28..d3adc756 100644
--- a/neutrinordp/Makefile.am
+++ b/neutrinordp/Makefile.am
@@ -1,20 +1,17 @@
-EXTRA_DEFINES =
-
-if XRDP_DEBUG
-EXTRA_DEFINES += -DXRDP_DEBUG
-else
-EXTRA_DEFINES += -DXRDP_NODEBUG
-endif
-
AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
-DXRDP_PID_PATH=\"${localstatedir}/run\" \
- $(EXTRA_DEFINES) \
-I$(top_srcdir)/common \
$(FREERDP_CFLAGS)
+if XRDP_DEBUG
+AM_CPPFLAGS += -DXRDP_DEBUG
+else
+AM_CPPFLAGS += -DXRDP_NODEBUG
+endif
+
module_LTLIBRARIES = \
libxrdpneutrinordp.la