summaryrefslogtreecommitdiffstats
path: root/sesman/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-01-29 22:45:00 -0800
committerPavel Roskin <plroskin@gmail.com>2016-01-29 22:45:00 -0800
commita452d8d36aafda4a873f8c035a3fe3fd51fabd96 (patch)
tree17ce42f7a222d165308585f6d8be3e205a5e95f0 /sesman/Makefile.am
parent309fca35acfeb776a422d6140ddae8be0b1dbff0 (diff)
downloadxrdp-proprietary-a452d8d36aafda4a873f8c035a3fe3fd51fabd96.tar.gz
xrdp-proprietary-a452d8d36aafda4a873f8c035a3fe3fd51fabd96.zip
Merge AM_CFLAGS and INCLUDES info AM_CPPFLAGS
AM_CPPFLAGS is for flags passed to the preprocessor, such as defines and includes. AM_CFLAGS is for flags affecting the compiler, such as debug and optimization settings. INCLUDES is an obsolete name. Users can pass INCLUDES and break compilation. AM_CPPFLAGS is more explicit that the flags come from Automake and should not be overridden.
Diffstat (limited to 'sesman/Makefile.am')
-rw-r--r--sesman/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/sesman/Makefile.am b/sesman/Makefile.am
index 55056031..979f72d9 100644
--- a/sesman/Makefile.am
+++ b/sesman/Makefile.am
@@ -2,13 +2,11 @@
EXTRA_DIST = sesman.ini startwm.sh sesman.h access.h auth.h config.h env.h \
scp.h scp_v0.h scp_v1.h scp_v1_mng.h session.h sig.h
-AM_CFLAGS = \
+AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
- -DXRDP_PID_PATH=\"${localstatedir}/run\"
-
-INCLUDES = \
+ -DXRDP_PID_PATH=\"${localstatedir}/run\" \
-I$(top_srcdir)/common \
-I$(top_srcdir)/sesman/libscp